Oracle Linux 7 : firefox (ELSA-2023-0296)
Discription

The remote Oracle Linux 7 host has a package installed that is affected by multiple vulnerabilities as referenced in the ELSA-2023-0296 advisory.

– Mozilla developers and the Mozilla Fuzzing Team reported memory safety bugs present in Thunderbird 102.6.
Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. (CVE-2023-23605)

– Regular expressions used to filter out forbidden properties and values from style directives in calls to console.log weren’t accounting for external URLs. Data could then be potentially exfiltrated from the browser. (CVE-2023-23603)

– A mishandled security check when creating a WebSocket in a WebWorker caused the Content Security Policy connect-src header to be ignored. This could lead to connections to restricted origins from inside WebWorkers. (CVE-2023-23602)

– An out of date library (libusrsctp) contained vulnerabilities that could potentially be exploited. This vulnerability affects Firefox DataTransfer.setData. (CVE-2023-23598)

– By confusing the browser, the fullscreen notification could have been delayed or suppressed, resulting in potential user confusion or spoofing attacks. This vulnerability affects Firefox Read More

Back to Main

Subscribe for the latest news:
Generated by Feedzy
%d bloggers like this: